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1. Plugin Purpose 
The 3D Fab Plugin for Solidworks serves two purposes: 
 

1. It converts solidworks weldment components into geometry that can be cut on a 4-axis 
laser cutter.  

2. It unwraps those weldment components and automatically saves a .dxf file that can be 
fed into FabCreator to create a file so the tubes can be cut. 

 
It works similarly to Solidworks’ built in “Convert to Sheet Metal” function, but it allows the user 
more control over how features get compensated so that all of your laser cut tubes fit together 
exactly as expected. 

1.1. About Weldments 
Weldments are a way of building a structure in a Solidworks Part that will provide the user with 
separate bodies that can be output to a file. The user can take those parts and make a cutlist for 
producing the tubes, which takes most of the guesswork out of the fabrication. 
 
It is convenient to use weldments, because as the user changes the base sketch (the frame of 
the weldment), each structural member will update with it. This allows for easy iteration of 
designs and revisions. The purpose of this plugin is to convert a weldment into a file that the 
laser can interpret. The nuances of the plugin are described in this document, but first, the 
workflow will be explained. This will give the user an idea of how to best design their parts for 
cutting on the FabLight. 

1.2. About Solidworks 
Solidworks is independent commercial software that is upgraded regularly. Unfortunately, files 
are often not compatible between versions, and instructions for how to do things in Solidworks 
can change. This manual is written for Solidworks 2015. If something is not working in your 
version of Solidworks, you can try searching online for an answer to your issue. You should also 
feel free to contact 3D Fab Light service (​service@3dfablight.com​) for help resolving the 
problem (or if you solved it, to let us know what you did). We aim to improve our documentation. 

1.3. Weldment Tutorial 
Describing how to use Solidworks weldments is beyond the scope of this document. There is a 
tutorial built into Solidworks by clicking Help > SOLIDWORKS Tutorials. Other tutorials can be 
found online. 
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1.4. Weldment Library 
There is a FabLight weldment library that includes a number of square and round tube profiles. 
This library is not required, but might be helpful, especially for square tubes. 
 

 
After downloading and unzipping the library, you can install the weldments into your weldment 
folder manually. To locate the folder, go to Tools > Options, then pick “File Locations” in the list 
and “Weldment Profiles” from the drop-down menu. The two folders in the library, FabLight 
Round and FabLight Square, can be moved into that location. Restart Solidworks to load the 
new libraries. 
 

 
 
Creating your own custom profiles is easy -- they are just 2D sketches showing the outline of 
the tube that will be created, that are saved into the Weldment Profiles location. If our library is 
giving you problems, you can recreate any weldment easily. 
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NOTE​: These profiles were made with Solidworks 2015, and may not open properly in newer 
or older versions due to Solidworks incompatibility issues. 

NOTE​: If creating a custom Weldment library folder, it needs to have at least two levels of 
folders for Solidworks to recognize it. For example, even though the round tube profile is the 
same for all materials, an extra “Any Material” folder must be in the path (e.g. FabLight Round 
> Any Material > 1 inch round, .035 inch wall.SLDLFP). 



 

1.5. Corner Radius 
The most important part of our weldment profiles is the corner radius, which affects the overall 
unwrapped perimeter of a square tube, so it is important to match it to the tube size you’re 
using. The corner radius value depends on the wall thickness of the square tube, but is 
independent of outer diameter and material type. The following are standard values we have set 
in our Weldment profiles: 
 

 
Note that if you create your own sketch for a square or rectangular tube, the inside and outside 
corner radii must be concentric for Solidworks to convert the tube to sheet metal for flattening. 

1.6. Multi-Profile Weldments Best Practice 
One thing to note is that if you have different size weldment profiles within your structure (e.g. 
different diameters, mixed round and square, etc), you can create separate structural member 
groups. Note that the separate groups will not terminate (cope) into each other. The user must 
do this.  
 
Normally the user will use trim/extend feature found in the weldments tab, HOWEVER, the 
plugin does not work with this feature -- the weldment will not process with this feature. 
Therefore, ​the user needs to use cut/extrude with an “up to body” end condition​. Be sure 
to not merge results and select the correct body. If the user would like to make a pipe for fluid 
flow, etc., now is the time to extrude/cut the orifices. From here you can run the plugin, as 
described in this document. 
 
This idea will be revisited later in context. For now, it is something to keep in mind when creating 
weldments. 
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Wall Thickness (in) Corner Radius (in) 

0.065 0.07 

0.120 0.13 

0.180 0.25 

0.250 0.38 



 

2. Installation 

2.1. Download and Install 
Download the plugin installer and install it. Also download the Weldment Library and install it in 
your Weldment Profile directory (see Weldment Library in section 1 for more info). The library 
includes common sizes of round and square tubes up to 0.120” wall and 2” diameter round and 
square. 
 
As with most design, it is important to keep in mind the capacity of the machine used to make 
your parts. The FabLight rotary chucks can cut up to 2” square and round tubes, up to 54” long 
(standard) or up to 80” long with the extension. 

2.1.1​.​ Activate Plugin Add In 
After installing the plugin, you will need to go to Solidworks Tools > Add Ins… and under Other 
Add-ins, check both boxes for 3DFabPlugin, then hit the OK button. The box on the left is to 
activate the plugin, and the one on the right is to start the plugin on Start Up of Solidworks. 
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2.1.2​.​ First View of the Plugin 
The plugin now appears in the Toolbar, much like Weldments. If the tab is not visible after 
activating, try right-clicking on another tab and then choosing 3D Fab Plugin from the list that 
appears. Once the tab is visible, selecting it reveals two options: Process tubes and Settings. 
 

 

2.1.3​.​ Licensing 
The 3D Fab Plugin is designed to be free to use, but requires registration. The plugin will work 
for up to 7 days without requiring registration. 
 
Registration is done by clicking Settings in the 3D Fab Plugin toolbar. This brings up the 
Settings window, as seen on the image below. Clicking on the the License Tab and pressing the 
“Send License Request” button opens another window asking for name, email, and company 
name. Customers can install it on as many copies of Solidworks as you’d like. We are just trying 
to monitor the number of licenses, and non-customer users. 
 

 
You will receive a license key sent to the email provided. Currently this is manually generated, 
so it might take a few hours to receive a reply. Please plan ahead for the 7 day trial period. 
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NOTE​: If you get a warning, “Please connect to the internet” after clicking “Send License 
Request,” you will have to email the HardwareID directly to ​swplugin@3dfablight.com​ using 
another email method. 

mailto:swplugin@3dfablight.com


 

When you receive the key, copy and paste it into the window that opens when the click the 
“Enter New License Key” button (see image below). This license key is good for 1 year, then the 
user needs to repeat the same process. 
 
  

 

2.2. Plugin Inputs 
The plugin can handle inputs from: 

1.) Multibody Solidworks weldment generated from a skeleton sketch. 
2.) Single or multibody tube structures generated using SW extrusions. 

 

2.3. Plugin Outputs 
The plugin outputs the following for each tube in the input file (more specifically, for each tube 
selected): 

1.) Compensated Geometry in a SW part file 
2.) Unwrapped tube DXF file, showing the flat pattern for the unwrapped tube 
3.) SW Assembly file showing how all the compensated parts fit together 

 
Even if you only run one tube, the plugin will still generate an assembly with only that part in it. 
See section “3.2.1. Output Files” for more details on the exported folder and files. 

 
 

Copyright 3D Fab Light, Inc., 2019 3D Fab Plugin Manual v2.0, page 8 of 25 

NOTE​: The plugin cannot currently handle STEP files or other types of “featureless” inputs. 
You will have to recreate the geometry in Solidworks weldments. 



 

2.4. Plugin Export Settings 
Clicking on the Settings button on the 3D Fab Plugin toolbar brings up the Settings Window. 
Besides the License tab (see 2.1.2 Licensing above) there is the Export settings tab. When you 
select your settings and click “Ok”, your selections will be remembered every time you open 
Solidworks until you manually change them again. When you first install the plugin, it is 
recommended you go into its settings and set them up as shown below. When you accept the 
settings by clicking “OK”, the system will remember them until you manually change them again. 
 

 
 

By default, the plugin enables Custom map Solidworks to DXF. When the plugin is installed, it 
points to a map file by default that places the cut geometry on Layer 0 and the Bend Lines on 
Layer “bend_lines”. This file can be ignored by unchecking the enable box, or can be modified 
by pointing to a different map file. 
 
End Point Merging can help clean up the exported .dxf file and is recommended to be enabled. 
 
It is also recommended to select “Export all splines as polylines,” as the FabLight works better 
with curves that are designed using arcs rather than splines. 
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3. Using the Plugin 

3.1. Plugin Options 
Now that the plugin is setup correctly and licensed, we will discuss the available compensation 
options and how to select them. 
 
When you click the “Process Tubes” button from the 3D Fab Plugin toolbar, it launches a 
sidebar. First select the bodies to compensate. You can select them individually or press the 
“Select All” button to automatically select every tube. 
 
The two main options to be aware of here are how the features on the tubes will be joined and 
normalized. 
 

 

3.1.1​.​ Joint Type 
This determines how the ends of the tubes will be compensated, either “Structural” or “Pipe”. 
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Structural joints​ compensate the edges of 
the tubes to the inner diameter (ID).  This 
means the tube can only contact the other 

Pipe joints​ only compensate the edges of 
the tubes to the outer diameter (OD). This 
means the tube can only contact the other 
tubes on it’s outer edge. In order for this type 



 

 
If the plugin fails to process, or out of curiosity for how it works, you can replicate the results 
manually by following the example for a Structural joint below: 
 
We are going to focus here on the tube that has the “fishmouth” end cut, to show how to 
compensate that cut manually. In the left image below, you can see that the tube comes to an 
infinitely sharp point at both the top and bottom. This feature is impossible to cut on the 
FabLight, because the cutting head doesn’t rotate, and therefore can’t cut the tube at an angle. 
It can only cut perpendicular to the tube (right image showing compensation to the ID). 
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tubes on it’s inner edge. It also maintains the 
section of all tubes (no added cuts). 

of compensation to mate up correctly, this 
requires a corresponding cut to be placed into 
the wall of the mating tube. This leads to a 
“fish mouth” type joint. It might be desirable if 
you need fluid to flow through your joint or for 
aesthetic reasons. 

 

  



 

 
The first step in compensating this end is to create a ruled surface to correspond to the ID edge. 
From the surfaces toolbar, select the ruled surface icon, shown circled in red in the left image 
below. 
 

  
 

When the screen launches, select the inner and toggle the distance, direction, and face so that 
it matches the image above.  
 
NOTE:​ The distance should be greater than or equal to the wall thickness of the tube.  
 
Click the green arrow to accept the surface. 
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Now, for ease of modeling, select the flat face on the opposite end of the tube and sketch two 
circles that match the ID and OD of the tube. Extrude this sketch so that it encompasses the 
entire tube, plus a little extra, as shown below. Be sure that the “Merge Result” box is not 
checked. 
 

 
 
Now go to Insert → Features → Delete/Keep Body. Select the original weldment body and 
delete it, as shown below. 
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Now go to Insert → Features → Intersect. Select the extruded body that is left on your screen 
and the ruled surface from the ID edge. Check the box to delete Region 2, as shown below, and 
check Merge Results at the bottom. 
 

 
 
Now the tube is normalized to only the ID.  
 

 

3.1.2​.​ Normalize Internal Features 
The second drop down menu is labeled “Normalize Internal Features To” and it is used to 
control how all cuts that are not on the edges (e.g. “internal” to the tube) are compensated. The 
options are compensation to Inner Edge, Outer Edge, or Both Edges. The example below 
illustrates the difference between the options. 
 

 
 

Copyright 3D Fab Light, Inc., 2019 3D Fab Plugin Manual v2.0, page 14 of 25 



 

Two identical 0.25” diameter circles have been cut-extruded in one of the structural members. 
 

 
 

After processing these tubes as Joint Type: Pipe, and Normalize Internal Features To: Both 
Edges, we get the resulting Compensated Assembly below. 
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Note the cut-extrusions show different shapes — circle for the inner diameter (ID), and elliptical 
for the outer diameter (OD). This is because the plugin outputs two Surface Cuts in the 
Compensated Assembly for each internal feature, one for the OD and one for the ID. When you 
Normalize to either Inner Edge or Both Edges, the OD Surface Cut is suppressed by default, 
meaning the ID is the edge that retains the original 0.25” measurement as shown below.  
 

 
 

In order to make it so that the OD retains the original 0.25” instead, you have to switch the “IF 
SurfaceCut ID” to be suppressed and make the “IF SurfaceCut OD” unsuppressed, as applied 
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to the bottom extrusion below. Notice how switching the suppression also switches the 
circle/elliptical shaping, such that the circle-shaped edge is the one that is unsuppressed and 
retains the expected dimension. The elliptical-shaped edge is the one that is suppressed and 
does not match the original extrusion dimension. 
 
IMPORTANT NOTE​: If you make manual adjustments like this to the processed part file, you 
need to Flatten the part in the Sheet Metal toolbar and resave the DXF manually. 
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NOTE:​ If you encounter the error below, the plugin is simply stating that for some reason it 
could not create SurfaceCuts for both the OD and ID, so you will not have a choice of which one 
to suppress. Click “Ok” and check the output file for any irregularities. If the error does not 
appear to have affected your desired design, you can ignore it. 

 

3.1.3​.​ Slit Location 
The final option in the setup is the slit location. This is an angular position between 0 and 360 
degrees that determines where the tube is cut before it is unwrapped. By default, this value is 
set to 0. This works in most cases, but if it cuts through features awkwardly or if the plugin does 
not run correctly, you can try to adjust the slit location and run it again. This is important 
because any features running along the slit will be split both in the DXF and in cutting and 
engraving. The slit should be moved away from any critical features to avoid any interruptions in 
the cut.  
 
SQUARE TUBE NOTE​: You should generally try to rotate the slit location on a square tube by 
factors of 90°. When you use FabCreator to process a DXF into a FAB file for cutting, 
FabCreator will assume the x axis of the unwrapped flat pattern is in the middle of a square 
tube. So if you rotate the slit by a value other than a factor of 90° without accounting for it in 
FabCreator, it will shift your design feature locations in an unintended manner. The example 
screenshots on the next page illustrate how a 0° (default), 20°, and 90° slit location value 
impacts the FabCreator wrapping and job preview of a square tube with cut features on all 
faces. 
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3.2. Running the Plugin 

3.2.1. Output Files 
After you select tubes, compensation options, and slit location, click the green Check Mark to 
run the compensation routine. When it’s finished, a new assembly called “Compensated 
Assembly.sldasm” will be open, made up of the processed part files that are automatically 
created. 
 
These files are in a folder that is automatically created in same directory as the part being 
processed. This folder uses the part file’s name to create “PARTNAME-FabLight-r1”. Inside this 
folder are a number of files. For a two-member weldment, there would be: 
 

● Compensated Assembly.sldasm 
● StructuralMember[1].dxf 
● StructuralMember[1].sldprt 
● StructuralMember[2].dxf 
● StructuralMember[2].sldprt 

 
The “Compensated Assembly.sldasm” is the file that is open. The two DXF files in that folder are 
the flattened output that will then go to FabCreator to make the FAB files. 
 
If you process the same file through the plugin more than once, you will be asked if you want to 
overwrite the existing output folder. If you select “No”, the plugin will continue to process but 
save the output to a folder with the end suffix “-r2”, and so forth for any future iterations. 
 

 
 

  

 
 

Copyright 3D Fab Light, Inc., 2019 3D Fab Plugin Manual v2.0, page 20 of 25 



 

3.2.2. Conversion Process Error 
There is currently a known bug with tubes that have cut-extrusions through their base end. If 
you see an error like the one below, use the following steps for our temporary workaround. 
 

 
 

In this example below, we have a square tube structural member made from a Factory 
weldment profile. There are cut-extrusions on both ends of the tube, a rectangle sketched on 
the end face of the tube, and a circle sketched on a side face.  
 

 
 
Only the rectangle extrusion will cause the conversion process error, because it is at the base 
end of the tube - the starting end of the sketch that the structural member is made from. If just 
the circle extrusion is suppressed, the same error will occur in the plugin. The cut-extrusion at 
the base of the tube, the rectangle, must be suppressed to properly process the plugin. Doing 
so results in the compensated assembly below that is missed the original rectangular feature we 
want. 
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The trick is to manually apply the erroneous feature post-processing. First you have to open the 
part from the compensated assembly. Then, from the original pre-processing file, enter the 
sketch for the erroneous extrusion at the base end of the tube and copy all the entities. 
 

 
 

Go back to the post-processing file that is missing the erroneous feature and paste the copied 
sketch onto the matching face, making sure to correct orientation and any other details not 
pasted. 
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Apply the cut-extrusion to the pasted sketch in the post-processed file to bring in the missing 
feature. Once the post-processed part file matches the pre-processed file, you must manually 
save it as a DXF to import into FabCreator. Select the “Sheet metal” Export option to get a flat 
unwrap of the tube. 
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4. Notes and Best Practices on the Plugin 
● Larger models tend to slow the plugin down, but if the tubes are relatively simple 

geometry (not too many cuts), the plugin usually completes. Note that it can take 
minutes, so be patient. 

● Internal features seem to really slow the plugin down and often cause it to crash. If you 
have a tube with 100 holes in it, it might be pretty challenging. 

● Internal features tend to behave better when you select “inner edge” or “outer edge” 
rather than “both edges”. 

● Adding tabs (for slots) to the end geometry in the weldment file currently crashes the 
plugin. However, using the Unfold feature, you can add tabs to the compensated sheet 
metal flat pattern. Draw on a plane that intersects the axis of the receiving tube, extrude 
cut the slot profile. Because the part is already a sheet metal feature, it will add the 
compensation to the bend around the cut profile. The DXF will have to be manually 
re-saved afterwards. 

● Currently, there is no support for extruded aluminum square tubes with sharp corners. 
This is because a sharp corner does not have a bend radius and therefore cannot be 
converted to sheet metal. If the ID and OD of the weldment are radiused, the plugin will 
process the tube, but will output an erroneous geometry.  

● Sometimes if you re-run the plugin after modifying or adding a weldment, the original 
part will remain in the assembly. Avoid this by deleting the old files in the output location 
(the same location as the weldment file) before re-running the plugin. 

● Plug-in does not seem to support Trim/Extend Weldment Feature. This feature would 
normally be used to cope a tube of one structure group into another. We are not certain 
of the functional difference, but a Cut/Extrude up to the coping surface (Up to Face 
Option) of the intersecting Structure group seems to work. You can also try a backwards 
approach by running the plug-in on the pre-coped tubes, then doing an extrude-cut on 
the compensated assembly that is created of the pre-coped tubes. 

● Plug-in does not support Hole-Wizard features. All holes will have to be extrude cut into 
a tube. 

● Plug-in can output a square tube file with a rotated slit location, but FabCAM will only 
assume the bottom of the flat pattern is in the middle of the profile. 

● The “Pipe” feature in the options does not seem to work on square tube. It only outputs 
structural joints. Only round tube is affected. This can be worked around if the 
intersection hole is modeled in the weldment.  
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5. Solidworks References 
Here are two references we used in creating the plugin, and which might help if you ever need 
to convert a tube to sheet metal or create ruled surfaces without the plugin. 
 

● Using ruled surfaces to create a normal cut path:  
https://forum.solidworks.com/thread/85466  

● Cut a slit and flatten tube like sheet metal: 
https://www.youtube.com/watch?v=dTR9FBEGzy8  

6. Non-Solidworks Users 
Here are a couple of links that might be helpful for users of non-Solidworks CAD software: 
 

● Inventor: 
https://forums.autodesk.com/autodesk/attachments/autodesk/78/413984/1/Creating%20
Coping%20Patterns%20in%20Inventor.doc 

● Solid Edge: ​https://www.youtube.com/watch?v=2PjtV-nakd0 
 

7. Service Through Freshdesk 
If a file is giving you trouble, or you need help processing it, you can attach it to a ticket on 
Freshdesk. Please include the Solidworks file and any output DXF files that were created. You 
may also submit tickets about plugin bugs or feature requests through Freshdesk. 
 
You can create an account here: ​https://3dfablight.freshdesk.com 
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